


Wouldn’t it be nice if you could wave a magic wand and make your design appear on a 

t-shirt?

We think so too. If you figure out how to do that, let us know. But until then, it’s crucial to 

know how to prepare your digital artwork files for production.

If you don’t have a design background or you’ve never ordered custom apparel before, you 

might not be aware of the optimal file formats and specifications for your artwork.

That’s why we created this little beauty: The Ultimate Artwork Preparation Guide for 

Custom Apparel.

We have this process down to a science, and we’re about to rock your world with a guide 

that answers all your questions on how to get your designs ready to print.

(And if you happen to have additional questions at the end, don’t worry. Our team is ready 

to answer them.)



It’s time to put down the Pen tool and put on your learning cap.

Although the technical details of the artwork preparation process may seem small, they are 

incredibly important. These intricacies are the difference between t-shirts from heaven and 

a custom apparel faux pas.

There’s nothing more disappointing than opening your custom apparel order only to find 

that the colors are mismatched and your artwork looks fuzzy.

BTW, that will never happen if you choose to work with us. Want to know why? Well, let’s 

take a look at the first step in our artwork preparation process:

1. Choose a custom apparel partner that will triple-check all the details 
of your project before putting it into production.

Artwork preparation means preventing mistakes, and that should be your custom apparel 

partner’s responsibility as well as your own.

Our amazing team and seamless Brand Building Process (BBP) eliminate the margin of 

error by extensively reviewing every last detail of your project to make sure there are no 

hiccups.

2. Decide in advance which printing technique, garment patterns, 
fabric, and ink you will use for the project.

Clarifying the basic details of your project will help you understand what to expect from 

your finished product.

It will also help you determine which kind of artwork file you’ll need to provide in order for 

your design to look its best on the final garment.

For example, if you’re using a discharge printing technique, your design should be 

Artwork preparation
will make or break

your finished products



vectorized. If you’re using a water-based ink on a dark t-shirt, we recommend using a high-

contrast color scheme.

If you’re unsure about which printing techniques, garments, fabrics, or inks to use, our 

team will be happy to help you decide based on your project goals.

3. Be mindful of the limitations of each printing technique.

Each printing technique has its own set of limitations that you need to be aware of when 

you’re creating your artwork. For example, certain effects often don’t look good when 

they’re screen printed.

Be cautious of these effects when creating your artwork to screen print:

•	 Drop shadow: The ink often bleeds, making the shadow appear messy.

•	 Gradient: The color transition might not be as smooth as you want it to be.

•	 Glow: The ink won’t achieve the same “glow” effect you’d get from looking at the image 

on a screen.

•	 Transparency: If you use overlapping colors that have less than 100% opacity, it will be 

difficult for the printer to achieve the same look you see on the screen because the ink 

transparencies can be unpredictable. Instead, you can use a spot color to ensure the 

overlapped section prints accurately.

Keep these limitations in mind when you’re creating your artwork so you can choose the 

best printing technique for your custom apparel project.



4. Create your design in Adobe Illustrator.

If you want your design to look amazing on a t-shirt—or any other product, for that 

matter—you need to create it in Adobe Illustrator.

Adobe Photoshop just doesn’t cut it when it comes to vector files, which is the only file type 

you should use for printing.

What’s a vector file?

Vector files (like AI or EPS) are made up of mathematical curves instead of a series of dots. 

Vectors can be scaled to any size without losing quality, unlike raster files.

What’s a raster file?

Raster images (like JPEGs or PNGs) become blurry and pixelated when they’re enlarged. So 

if you want your design to look crisp and clean on a t-shirt, you need to start with a vector 

file.

How to create a vector file

There are a few different programs you can use to create vector files, but Adobe Illustrator 

is by far the most popular (and for good reason). Illustrator offers an incredible amount of 

control and flexibility when it comes to creating artwork for printing.



If you’re not already familiar with Illustrator, we recommend taking some time to learn the 

basics before you start working on your design.

There are lots of great tutorials online (thanks to our friends Google and YouTube). And 

you can even try Illustrator for free by signing up for a 7-day trial of Adobe Creative Cloud.

Not everyone is a digital artist, and that is completely okay!

If you’re someone who likes to draw their designs by hand, the best thing you can do is 

scan your artwork into a computer and trace over it in Illustrator using the Pen tool.

That may sound like a lot of work, but it’s actually pretty easy to do. And once you get the 

hang of it, you’ll be able to create vector files from your hand-drawn designs in no time.

Plus, tracing your artwork in Illustrator will give you a lot more control over your design 

than if you were to just scan it in as a raster image.

Here’s a quick tutorial on how to trace a hand-drawn design in Illustrator:

1.	 Start by scanning your artwork into the computer. Make sure the scan is at least 300 

DPI.

2.	 Open the scanned image in Illustrator and select the “Pen” tool from the toolbar.

3.	 Use the Pen tool to trace over the outline of your artwork. Try to stay as close to the 

original linework as possible.

4.	 Once you’ve finished tracing the outline of your design, delete the scanned image and 

you’re done!

What to do if you draw your custom 
apparel designs by hand

https://www.adobe.com/downloads.html


5. Create a mockup of your design to see what it will look like when it’s 
printed on the apparel.

This will help you visualize the final product and make sure that the sizing, placement, and 

colors are all perfect.

There are a few different ways to create mockups, but we recommend using Adobe 

Photoshop.

Once you have your design ready in Illustrator, simply open it in Photoshop and place it on 

the mockup template.

You can find lots of great free mockup templates online, and in fact, we have several 3D 

Apparel Templates that are picture-perfect representations of our own garments.

https://scrappyapparel.com/scrappy-free-resources/
https://scrappyapparel.com/scrappy-free-resources/


6. Create your artwork in its actual size.

This may seem like a no-brainer, but it’s actually one of the most common mistakes we see 

people make.

When you’re designing your artwork, you need to make sure to create it at its actual size 

because t-shirts (and other garments) are printed on large format printers.

Your artwork will be printed at 100% scale, so if it’s not the right size, it will either be too 

small or too large.

7. Keep in mind that intricate details and ultra-fine lines may not 
translate to the finished product.

If your design is too detailed, it may need to be simplified in order for it to print well.

And if you’re using a printing technique like screen printing, keep in mind that the screens 

themselves have a limited resolution.

This means that super fine details might get lost in the printing process. 

We recommend ensuring that all your lines are at least 0.3 pt thickness so they can be 

printed accurately. 

8. For a cost-effective design, use solid colors and stick to a few of them. 
(Not a million.)

We know, it’s tempting to go overboard with color when you’re creating your custom 

apparel design. But trust us, less is usually more.

Why? Because more colors = more expensive.

Each color requires a separate screen to be made, and each screen costs money.

If you want to keep your design cost-effective, we recommend using a limited color palette. 

And if you really want to keep the price low, stick to one or two colors. Solid colors are the 

most economical option.



When it comes to choosing colors for your design, there are a few things you need to 

keep in mind:

First, you’ll want to make sure that the colors you choose will look good on the garment 

color you’ve chosen. 

For example, if you’re printing on a dark shirt, you’ll want to use light colors so your design 

will be visible.

If you’re printing on a light garment, you can use darker colors without any problems

Just be sure to avoid using colors that are too close to the shirt color. (This can make your 

design difficult to read.)

Another thing to keep in mind is that some colors are more difficult (and therefore more 

expensive) to print than others.

For example, metallics and fluorescent colors can be tricky to print, so you’ll want to avoid 

using them if you’re trying to keep costs down.

9. Ensure all typography is large enough to be readable.

This is especially important if you’re using a small font size.

When in doubt, use a larger font size than you think you need because it will be difficult to 

read if it’s too small.

And if you’re using a script or handwriting-style font, make sure it’s legible by testing it out 

on different people.

The last thing you want is for your custom apparel to be unreadable!



10. Test temporary background colors behind your design to see what 
the artwork will look like on different apparel colors.

Since t-shirts (and other apparel) come in a variety of colors. It’s important to test your 

artwork on as many different backgrounds as possible, especially if you plan on ordering 

shirts in multiple colors.

The easiest way to do this is to create a new layer in Photoshop and fill it with a solid color. 

Then, position your artwork on top of the colored layer and change the opacity of the layer 

so you can see your design on top of the background.

Repeat this process for as many different colors as you want to test.

11. Save your artwork in the right file format.

When you’re exporting your file, make sure you save it as an EPS or AI file. These are both 

vector file formats that can be opened in Illustrator.

If you save your file as a JPEG or PNG, it will be saved as a raster image, which means it will 

lose its quality when it’s printed.



12. Use CMYK or Pantone (PMS) color modes.

When you’re creating your artwork, you need to make sure it’s in either CMYK or Pantone 

(PMS) color mode. These color modes are used for printing.

Let’s take a look at the use cases of each color mode:

•	 CMYK: Used for printing on paper. It’s a subtractive color mode, which means it starts 

with white and then adds cyan, magenta, yellow, and black ink.

•	 RGB: Used for digital displays (like your computer screen). It’s an additive color mode, 

so it starts with black and then adds light in the form of red, green, and blue.

•	 Pantone: Used for printing on fabric. It’s a spot color mode, which means that each 

color is printed as its own ink (rather than being mixed together).

For precise color matches, Pantone is the way to go.

How to change the color mode in Adobe Illustrator

If your file is in RGB, you can change the color mode by going to File > Document Color 

Mode > CMYK.



13. Embed all linked images and textures.

If your artwork has any linked images or textures, you need to embed them before you 

send the design off to be printed.

Linked images are not fully part of your Illustrator document. Think of them as hyperlinks—

they point in a certain direction, but the links themselves do not contain all the content.

To embed an image, select it and go to Edit > Embed.

If you want to embed a texture, click on the image and then go to Object > Rasterize.



14. Convert all text to outlines.

Fonts are just like linked images—they are not fully embedded into the Illustrator file. 

When you transfer the file to someone else, the font will only carry over if the recipient has 

the same font installed on their computer.

That’s why you need to make sure to convert all your text to outlines before exporting your 

artwork.

To convert your text to outlines, select it and then go to Type > Create Outlines.



15. Expand all strokes.

Before exporting your file, make sure all strokes are expanded.

Expanding strokes ensures that your design will be printed correctly and there won’t be any 

white gaps around the edges of your lines.

To expand your strokes, select them and then go to Object > Expand.



16. Allow your custom apparel partner to adjust the halftones for you.

Halftones are the tiny dots that make up a printed design, and they need to be adjusted 

depending on the printing technique that’s being used.

For example, screen printing uses a coarser halftone than digital printing, so if you’re going 

to screen print your design, you need to make sure the halftones are adjusted accordingly.

We don’t recommend trying to mess with the halftones on your own, however. It’s 

something your custom apparel partner can do for you. All you need to do is send them 

your artwork in the right color mode (CMYK or Pantone) and they’ll take care of the rest.



Our custom apparel experts are ready to assist you. In fact, answering questions 

is one of our favorite hobbies.

For general inquiries, we’re available Monday through Friday from 10 am – 5 

pm. Call 833-SCRAPPY (833-727-2779) to get in touch with us.

If you’re ready to get your custom apparel project rolling, we are too!

Schedule a call with one of our Scrappy Sales Reps to get the party started:

If you’re unsure, just ask!

https://scrappyapparel.com/estimate/

